Announcement

Collapse
No announcement yet.

New Version of Subspace on a Mac

Collapse
This is a sticky topic.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Originally posted by qan View Post
    To run on El Capitan you have to update the wineskin from what I understand. Check here:

    http://forums.trenchwars.org/showthr...TW-on-Mac-OS-X
    I tried this also, porting kit freezes when updating wineskin

    Comment


    • #17
      Originally posted by Moos View Post
      I tried this also, porting kit freezes when updating wineskin
      1) Trash your current skin
      2) Check your IOS version (click on apple symbol - top left corner -> "about this mac"
      3) http://portingkit.com/en/ -> download new wineskin
      4) Drag the subspace icon into the wineskin
      5) Enjoy the game
      President of ?Go wbduel
      Hero of ?go Bug
      Trivia Master of ?go pub
      M3 student doctor (MD/MBA)
      Fide Candidate Master 2262 elo
      Solved over 600 evil sudokus (avrg time 6 mins)
      Future Trenchwars Sysop 2050
      Returning Dec 2017

      Comment


      • #18
        Originally posted by Hero Lrim View Post
        1) Trash your current skin
        2) Check your IOS version (click on apple symbol - top left corner -> "about this mac"
        3) http://portingkit.com/en/ -> download new wineskin
        4) Drag the subspace icon into the wineskin
        5) Enjoy the game
        Done

        Comment


        • #19
          Originally posted by Moos View Post
          Done

          I see. What OSX version are you using? I'm on the latest El Capitan and it works fine.

          Also, try uninstalling continuum & reinstalling. Open the app w/o opening the wineskin and opening the app in the wineskin application. Once you put the app on the portingkit, it will run w/o needing to open the wineskin. Play around and let me know if this works.
          President of ?Go wbduel
          Hero of ?go Bug
          Trivia Master of ?go pub
          M3 student doctor (MD/MBA)
          Fide Candidate Master 2262 elo
          Solved over 600 evil sudokus (avrg time 6 mins)
          Future Trenchwars Sysop 2050
          Returning Dec 2017

          Comment


          • #20
            Originally posted by Hero Lrim View Post
            I see. What OSX version are you using? I'm on the latest El Capitan and it works fine.

            Also, try uninstalling continuum & reinstalling. Open the app w/o opening the wineskin and opening the app in the wineskin application. Once you put the app on the portingkit, it will run w/o needing to open the wineskin. Play around and let me know if this works.
            I use ElCapitan 10.11.6.

            When I press play Continuum in Porting Kit, it asked me update Wineskin 2.5.8 to the recent 2.6.2. and after I press Yes to update, Porting Kit and Continuum become not responding

            Comment


            • #21
              Originally posted by Moos View Post
              I use ElCapitan 10.11.6.

              When I press play Continuum in Porting Kit, it asked me update Wineskin 2.5.8 to the recent 2.6.2. and after I press Yes to update, Porting Kit and Continuum become not responding
              Try this: Remove Subspace/TW from your laptop. Then go on Porting Kit -> upper left corner next to the apple icon and click on "check for updates" -> download the latested porting kit. Reinstall the game and try again.

              Let me know if this works.
              President of ?Go wbduel
              Hero of ?go Bug
              Trivia Master of ?go pub
              M3 student doctor (MD/MBA)
              Fide Candidate Master 2262 elo
              Solved over 600 evil sudokus (avrg time 6 mins)
              Future Trenchwars Sysop 2050
              Returning Dec 2017

              Comment


              • #22
                If all else doesn't work. PM me your email and I'll send you my version of Porting Kit
                President of ?Go wbduel
                Hero of ?go Bug
                Trivia Master of ?go pub
                M3 student doctor (MD/MBA)
                Fide Candidate Master 2262 elo
                Solved over 600 evil sudokus (avrg time 6 mins)
                Future Trenchwars Sysop 2050
                Returning Dec 2017

                Comment


                • #23
                  Originally posted by Hero Lrim View Post
                  Try this: Remove Subspace/TW from your laptop. Then go on Porting Kit -> upper left corner next to the apple icon and click on "check for updates" -> download the latested porting kit. Reinstall the game and try again.

                  Let me know if this works.
                  Porting Kit freezes when pressed the update

                  Comment


                  • #24
                    Originally posted by Hero Lrim View Post
                    If all else doesn't work. PM me your email and I'll send you my version of Porting Kit
                    My Porting Kit Version 2.3 (2.3.87)

                    Comment


                    • #25
                      Originally posted by Moos View Post
                      My Porting Kit Version 2.3 (2.3.87)
                      You may need to degrade to an earlier version. Inbox me your email and I'll send you my version which is currently working.
                      President of ?Go wbduel
                      Hero of ?go Bug
                      Trivia Master of ?go pub
                      M3 student doctor (MD/MBA)
                      Fide Candidate Master 2262 elo
                      Solved over 600 evil sudokus (avrg time 6 mins)
                      Future Trenchwars Sysop 2050
                      Returning Dec 2017

                      Comment


                      • #26
                        Originally posted by Hero Lrim View Post
                        You may need to degrade to an earlier version. Inbox me your email and I'll send you my version which is currently working.
                        Done

                        Comment


                        • #27
                          Originally posted by Hero Lrim View Post
                          You may need to degrade to an earlier version. Inbox me your email and I'll send you my version which is currently working.
                          Same as before

                          Comment


                          • #28
                            Originally posted by Moos View Post
                            Same as before
                            Next step: nag the developer to release a mac-compatible version or buy a windows PC.
                            President of ?Go wbduel
                            Hero of ?go Bug
                            Trivia Master of ?go pub
                            M3 student doctor (MD/MBA)
                            Fide Candidate Master 2262 elo
                            Solved over 600 evil sudokus (avrg time 6 mins)
                            Future Trenchwars Sysop 2050
                            Returning Dec 2017

                            Comment


                            • #29
                              New Version of Subspace on a Mac

                              Hi Guys,

                              I updated the Continuum Wrapper to use Wine 3.0. I have tested on Sierra and it works great. Also tested this on a 10.6 Snow Leopard machine and it worked as well.

                              I will have a High Sierra machine to test on tomorrow and I will let you know how that goes.

                              Here is the link for the 3rd mac version (c): Continuum_040c_Mac.zip

                              Let me know if it works for you! Not that I can promise soon but I will work on a 64 bit version next for future compatibility past High Sierra.

                              - Matt

                              Comment


                              • #30
                                Originally posted by spiffyguy View Post
                                Hi Guys,

                                I updated the Continuum Wrapper to use Wine 3.0. I have tested on Sierra and it works great. Also tested this on a 10.6 Snow Leopard machine and it worked as well.

                                I will have a High Sierra machine to test on tomorrow and I will let you know how that goes.

                                Here is the link for the 3rd mac version (c): Continuum_040c_Mac.zip

                                Let me know if it works for you! Not that I can promise soon but I will work on a 64 bit version next for future compatibility past High Sierra.

                                - Matt
                                Bizarre timing. Just fucked up and removed some stuff on my Mac to make storage space and now SS doesn't work. I'll give your version a try and get back to you with results. Thanks.

                                EDIT: worked. you're the fucking man. owe you 1
                                Last edited by Pressure; 03-01-2018, 08:02 PM.
                                4:Best> pressure was a terr for halloween 4:Best> guy had 4 dudes on him attached

                                4:Siaxis> what time is it in zimbobwe para?

                                4:Children> every morning i wake up, look in the mirror and thank god i'm not paradise

                                4:Best> Mighty's forehead has wifi

                                4:Mighty> u guys ever eat a ketchup sandwich?

                                4:sphinx> mighty fought a raccoon in an alley for some bbq chips

                                4:RaCka> so what if paradise is dressing up as a slim jim for halloween?

                                Comment

                                Working...
                                X