Announcement

Collapse
No announcement yet.

Client Performance

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Zeebu
    replied
    there used to be a way to force it to a proper resolution with black bars on either side to adjust for the mismatch

    Leave a comment:


  • Rab
    replied
    Nah it's a PC at 100%

    I'm just trying to say I'm 20 years used to this: https://imgur.com/tk9Bxpp

    To satisfy the res limit I get a window that looks like this: https://imgur.com/pfHJ6xk

    It starts in the top left corner every time. So I try to drag it centred, but don't get it exactly the same every time.

    Notice how my radar, nrg, etc. are not where I'm used to looking.

    1920x1080 does not go into 2560x1440p exactly, so any attempt to full screen a res within the limit will blur.
    Last edited by Rab; 04-22-2022, 10:00 AM.

    Leave a comment:


  • Zeebu
    replied
    Originally posted by Rab View Post
    Aim is 100x better in fullscreen(1440p) compared to windowed(1920x1200) as enforced by all competitive wb arenas. Res limit rules me out from even attempting to compete at wb. I think a big part of it is having the ship centered.

    Edit: ... and having radar + energy in the place I'm trained to glance at.
    just checking, but you dont have scaling on, do you? my laptop used to do really dumb things when i tried to make it go into full screen. turns out i was scaling to 125% and it couldnt cope and the display did dumb things.

    youre much better at computery things than me though so this is likely not the issue, but just wanted to check

    Leave a comment:


  • Rab
    replied
    I've been testing wifi adapter settings for a couple of weeks, game feels better, although it's hard to prove.


    Packet Coalescing

    "Packet Coalescing" can also be called "Interrupt Moderation" so substitute where appropriate.

    Instructions to disable wifi "Packet Coalescing" on Windows 10
    1. Open Control Panel > Network and Sharing Centre
    2. Click "Change adapter settings" (on the left)
    3. Right click on your wifi adapter > Properties
    4. Click the button "Configure"
    5. Click the tab "Advanced"
    6. Set "Packet Coalescing" to "Disabled"

    WTF does this setting do?
    Source: https://steamcommunity.com/sharedfil.../?id=727946014
    Interrupt Moderation

    RECOMMENDATION:
    Turn off if you can afford to; your mileage may vary.

    REASON(S) TO TURN OFF:
    Acts like a packet buffer for sending interrupts. “Allows the network driver to wait for enough packets of information to be generated before sending them, lowering the necessary number of times the driver has to send an interrupt message, which in turn lowers the CPU latency. However this has a negative effect in situations where it is necessary for data to be sent immediately. Disabling Interrupt Moderation will slightly increase CPU time; however the trade off is better registry in games” (SOURCE: [PSA] REDDIT).
    “Disable the Interrupt Moderation setting for network card drivers that require the lowest possible latency” (SOURCE: TechNet). Even Microsoft agrees.

    REASON(S) TO LEAVE ON:
    Depending on the program and the hardware, you may not have the CPU runtime to spare, as turning Interrupt Moderation off “can use more CPU time and it represents a trade-off” (SOURCE: TechNet). It’s possible that without this setting on, you will lose performance by increasing the already taxed CPU-load.
    Other theoretical reasons are that it improves latency at the CPU and the gains on that level exceeds the loss of latency in the network... or the NIC can handle the offloads/buffers enough to justify the CPU latency gains.

    AUTHOR’S NOTE:
    This is usually the biggest culprit of the primaries. This is due to the idea of ‘one packet, one interrupt’ which helps mitigates non-recoverable packet losses common to problematic online gaming. The principle is that one packet comes in, it gets a response from your system, the CPU turns it around back to the network card and it goes back out, for each packet. When they build up, the interrupts leaving your system pile up and delay your response. It’s hard to see how this couldn’t make any online gameplay that relied on time-critical elements problematic.

    MTU Size

    Instructions to set the correct MTU size (Do it for both ipv4 and ipv6)
    https://homenetworkgeek.com/mtu-size/

    WTF does this setting do?
    MTU size is the maximum packet size that can be transmitted over your network. Finding the best MTU size and changing it is worth doing should you experience a decrease in speed, lag or even complete disconnections on your network.

    If your line has a Maximum Transmission Unit (MTU) limit of 1492 bytes per packet and Windows is trying to send 1500 bytes per packet, your line will constantly snip 8 bytes off the Windows-borne packet, causing fragmentation. Fortunately, while divining the correct value is its own work, the process of changing the MTU value is relatively simple and painless. You just have to be willing to use command-line!
    Last edited by Rab; 04-22-2022, 06:52 AM.

    Leave a comment:


  • Rab
    replied
    Aim is 100x better in fullscreen(1440p) compared to windowed(1920x1200) as enforced by all competitive wb arenas. Res limit rules me out from even attempting to compete at wb. I think a big part of it is having the ship centered.

    Edit: ... and having radar + energy in the place I'm trained to glance at.
    Last edited by Rab; 04-22-2022, 08:19 AM.

    Leave a comment:


  • Rab
    replied
    Updated nvidia driver(496.76) and now 1440p 144fps works again.

    Leave a comment:


  • Rab
    replied
    for ages i've been playing 1440p 144fps, which has been okay, but trying to play in a window would totally mess up the settings - seemingly at random.

    now I have a newer nvidia driver(472.12) because of D2R, and reinstalled ss, and now the situation is totally different...

    the game won't go over 60fps in full screen mode, but will quite happily play in a 1920x1200 window at 144fps.

    does still randomly change settings though, restarted my pc and the game started using 1920x1440 full screen lul.

    fun times.

    Leave a comment:


  • Rab
    replied
    Some games don't have the option for Fullscreen, only Windowed or Fullscreen (windowed) modes. If you play a game like that, e.g. WOW, you have no choice but to enable GSync for windowed mode.

    this also applies a frame rate limit to the windowed game, so if you're used to 600+ fps, then you turn this on and you get 150fps, even though GSync is meant to be working it actually looks less smooth.

    Leave a comment:


  • Nipple Nibbler
    replied
    Originally posted by Rab View Post
    Note that when you get a 144hz monitor you need to change windows display properties from 60hz to 144hz.
    Must be tons of people with 144hz monitors who are still running at 60hz.

    [/URL]
    Rab I am one of those idiots that did not know this. Just changed the setting, thanks. Really dumb windows does not do this by itself.

    Leave a comment:


  • Rab
    replied
    Interesting video on audio delay
    https://www.youtube.com/watch?v=JTuZvRF-OgE

    Leave a comment:


  • Rab
    replied
    Edit: This post is wrong now (2022-04-22). Nvidia driver releases changed how GSync works. Choosing "windowed and full screen mode" doesn't hurt Continuum now.

    This setting is terrible, but it does have a big impact on the game so making a note of it:

    Note that I'm playing in a 1920x1200 window on a 1440p monitor, so this setting essentially means off/on for me.



    "full screen mode" (default)
    - means that GSync only works when playing games in full screen mode, when playing in full screen mode a frame rate limit is applied

    "windowed and full screen mode"
    - also enabled GSync in windowed mode, this also applies a frame rate limit to the windowed game, so if you're used to 600+ fps, then you turn this on and you get 150fps, even though GSync is meant to be working it actually looks less smooth.
    Last edited by Rab; 04-22-2022, 08:17 AM.

    Leave a comment:


  • Rab
    replied
    Videos on screen tearing, vsync, gsync, freesync.

    A brief video about screen tearing:
    https://www.youtube.com/watch?v=b-9uCXMznv8

    A long more techy video:
    https://www.youtube.com/watch?v=KhLYYYvFp9A

    Leave a comment:


  • Rab
    replied
    I did end up getting a gsync compatible 144hz 1440p monitor, which I used for the TWL season we just finished.
    Defo felt an improvement to my play as a result.
    Jav maps are still clearly laggier than other maps, idk why. I just gave up playing jav altogether.
    I think a 240hz monitor would be even better because even at 144hz it's not completely smooth.

    Note that when you get a 144hz monitor you need to change windows display properties from 60hz to 144hz.
    Must be tons of people with 144hz monitors who are still running at 60hz.

    With gsync you need to check the nvidia control panel to make sure gsync is enabled.

    This monitor also has a feature called ELMB Sync, which allows black frame insertion to work alongside gsync, which is great but it's another thing that's off by default and should be enabled.
    my monitor: https://www.rtings.com/monitor/reviews/asus/tuf-vg27aq
    Last edited by Rab; 06-30-2020, 08:49 AM.

    Leave a comment:


  • qan
    replied
    I'm getting maybe 45% GPU usage, quite ridiculous. That's a shame the framerate limiter doesn't seem to work with Cont.

    Seems as though there should be a way to force this all onto the CPU, something along those lines. Certainly things are very wrong somewhere.

    Leave a comment:


  • Rab
    replied
    I installed the 441.87 GeForce driver to test the framerate limiter, but before I got to that I noticed some changes:

    In a 1920x1200 window:
    with "no framerate limit" OFF (in-game limit on)
    previous driver: ~360fps, gpu ~30%
    new driver: ~100fps, gpu ~40%
    with "no framerate limit" ON (in-game limit off)
    previous driver: ~700fps
    new driver: ~700fps, gpu ~85%

    At 2560x1440 full screen:
    with "no framerate limit" OFF (in-game limit on)
    previous driver: ~270fps, gpu ~75%
    new driver: ~100fps, gpu ~30%
    with "no framerate limit" ON (in-game limit off)
    previous driver: unplayable due to maxed out gpu
    new driver: ~250fps, gpu: ~70%

    Findings:
    1. The new driver changes the behaviour of the in-game framerate limiter, causing it to limit to 100fps. It used to limit a lot higher, not sure what the logic was.
    2. The frame rate limiter feature in the new driver doesn't work for Continuum at all.
    3. The consequence of this is: to avoid maxing your gpu, from this driver onwards the only way to do it is to reduce resolution.
    Last edited by Rab; 01-19-2020, 05:15 PM.

    Leave a comment:

Working...
X